Difference between revisions of "GetBlobByName"

From King Arthur's Gold Wiki
Jump to: navigation, search
(Created page with "<onlyinclude> Returns a reference to the first CBlob with the given name. Probably not very useful. </onlyinclude> <syntaxhighlight lang="cpp">CBlob@ getBlobByName(const ...")
 
Line 2: Line 2:
 
Returns a reference to the first [[CBlob]] with the given name. Probably not very useful.
 
Returns a reference to the first [[CBlob]] with the given name. Probably not very useful.
 
</onlyinclude>
 
</onlyinclude>
<syntaxhighlight lang="cpp">[[CBlob]]@ getBlobByName(const string &in name)</syntaxhighlight>
+
<syntaxhighlight lang="cpp">CBlob@ getBlobByName(const string &in name)</syntaxhighlight>
  
 
This will not likely be that useful. It returns the first [[CBlob]] it finds with the given name. As most [[CBlob]]s will have a fairly generic name, there will often be lots of [[CBlob]]s with the same name, so you'd be better off using something like [[getBlobByNetworkId]] if you need precision.
 
This will not likely be that useful. It returns the first [[CBlob]] it finds with the given name. As most [[CBlob]]s will have a fairly generic name, there will often be lots of [[CBlob]]s with the same name, so you'd be better off using something like [[getBlobByNetworkId]] if you need precision.

Revision as of 16:50, 15 August 2012

Returns a reference to the first CBlob with the given name. Probably not very useful.

CBlob@ getBlobByName(const string &in name)

This will not likely be that useful. It returns the first CBlob it finds with the given name. As most CBlobs will have a fairly generic name, there will often be lots of CBlobs with the same name, so you'd be better off using something like getBlobByNetworkId if you need precision.